High severity vulnerability was found in npm ckeditor4 (npm) .

Affected packages

The vulnerability has been discovered in the Advanced Content Filter (ACF) module and may affect all plugins used by CKEditor 4.

Impact

A potential vulnerability has been discovered in CKEditor 4 Advanced Content Filter (ACF) core module. The vulnerability allowed to inject malformed HTML bypassing content sanitization, which could result in executing JavaScript code. It affects all users using the CKEditor 4 at version < 4.17.0.

Patches

The problem has been recognized and patched. The fix will be available in version 4.17.0.

The CKEditor 4 team would like to thank Maurice Dauer (laytonctf) for recognizing and reporting this vulnerability.

References


Courtesy:https://github.com/advisories/GHSA-pvmx-g8h5-cprj

By admin

Leave a Reply

Your email address will not be published. Required fields are marked *