Moderate severity vulnerability was found in gomod github.com/edgexfoundry/app-functions-sdk-go (go) .

Summary

Broken encryption in app-functions-sdk “AES” transform in EdgeX Foundry releases prior to Jakarta allows attackers to decrypt messages via unspecified vectors.

Detailed Description

The app-functions-sdk exports an “aes” transform that user scripts can optionally call to encrypt data in the processing pipeline. No decrypt function is provided. Encryption is not enabled by default, but if used, the level of protection may be less than the user may expects due to a broken implementation in https://github.com/edgexfoundry/app-functions-sdk-go/blob/v1.0.0/pkg/transforms/encryption.go

Version v2.1.0 (EdgeX Foundry Jakarta release and later) of app-functions-sdk-go/v2 deprecates the “aes” transform and provides an improved “aes256” transform in its place. The broken implementation will remain in a deprecated state until it is removed in the next EdgeX major release to avoid breakage of existing software that depends on the broken implementation.

Impact

As the broken transform is a library function that is not invoked by default, users who do not use the AES transform in their processing pipelines are unaffected. Those that are affected are urged to upgrade to the Jakarta EdgeX release and modify processing pipelines to use the new “aes256” transform.

Vulnerable go modules

  • github.com/edgexfoundry/app-functions-sdk-go < v2.1.0
  • github.com/edgexfoundry/app-functions-sdk-go/v2 < v2.1.0
  • github.com/edgexfoundry/app-service-configurable < v2.1.0

Vulnerable containers

Vulnerable Snaps

Patches

Upgrade to 2.1.0 version of app-functions-sdk-go/v2, app-service-configurable, and related docker containers shown below and modify user scripts to use the new “aes256” transform in place of the existing “aes” transform.

Patched go modules

  • github.com/edgexfoundry/app-functions-sdk-go/v2 v2.1.0
  • github.com/edgexfoundry/app-service-configurable v2.1.0

Modification of user scripts is necessary for full remediation.

Patched containers

Modification of user scripts is necessary for full remediation.

Patched Snaps

Modification of user scripts is necessary for full remediation.

Workarounds

If unable to upgrade, change the processing pipeline to use an HTTPS (TLS 1.3) endpoint to export and skip encryption.

References

References


Courtesy:https://github.com/advisories/GHSA-6c7m-qwxj-mvhp

By admin

Leave a Reply

Your email address will not be published. Required fields are marked *