Moderate severity vulnerability was found in bundler date (RubyGems) .

Date’s parsing methods including Date.parse are using Regexps internally, some of which are vulnerable against regular expression denial of service. Applications and libraries that apply such methods to untrusted input may be affected.

The fix limits the input length up to 128 bytes by default instead of changing the regexps. This is because Date gem uses many Regexps and it is possible that there are still undiscovered vulnerable Regexps. For compatibility, it is allowed to remove the limitation by explicitly passing limit keywords as nil like Date.parse(str, limit: nil), but note that it may take a long time to parse.

Please update the date gem to version 3.2.1, 3.1.2, 3.0.2, and 2.0.1, or later. You can use gem update date to update it. If you are using bundler, please add gem “date”, “>= 3.2.1” to your Gemfile.

References


Courtesy:https://github.com/advisories/GHSA-qg54-694p-wgpp

By admin

Leave a Reply

Your email address will not be published. Required fields are marked *