High severity vulnerability was found in npm @backstage/plugin-auth-backend (npm) .

Impact

This vulnerability allows a malicious actor to trick another user into visiting a vulnerable URL that executes an XSS attack. This attack can potentially allow the attacker to exfiltrate access tokens or other secrets from the user’s browser. The default CSP does prevent this attack, but it is expected that some deployments have these policies disabled due to incompatibilities.

Patches

This is vulnerability is patched in version 0.4.9 of @backstage/plugin-auth-backend.

References


Courtesy:https://github.com/advisories/GHSA-w7fj-336r-vw49

By admin

Leave a Reply

Your email address will not be published. Required fields are marked *