High severity vulnerability was found in npm @backstage/plugin-scaffolder-backend (npm) .

The templating library used by the scaffolder backend assumes that templates are trusted which is an undesired property of the scaffolder-backend. This has now been mitigated by sandboxing the template code execution.

Impact

A malicious actor with write access to a registered scaffolder template could manipulate the template in a way that allows for remote code execution on the scaffolder-backend instance. This was only exploitable in the template yaml definition itself and not by user input data.

Patches

This is vulnerability is patched in version 0.15.14 of @backstage/plugin-scaffolder-backend.

References


Courtesy:https://github.com/advisories/GHSA-2g8g-63j4-9w3r

By admin

Leave a Reply

Your email address will not be published. Required fields are marked *